$re = '/([EWSN])([0-9]{3})([0-9]{2})/m';
$str = 'E16130
W16130
S16130
N16130';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);