#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m) |<(?!\/?(?:li|ul|a)\b)\/?[^>]+(?:>|$)"
Local $sString = "<a href="ddd">eee</a><p> some text </p> and <li>text</li> <li/> <a/> <a /> " & @CRLF & _
"<ul> </ul>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")