re = / |<(?!\/?(?:li|ul|a)\b)\/?[^>]+(?:>|$)/m
str = '<a href="ddd">eee</a><p> some text </p> and <li>text</li> <li/> <a/> <a />
<ul> </ul>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end