using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" |<(?!\/?(?:li|ul|a)\b)\/?[^>]+(?:>|$)";
string input = @"<a href=""ddd"">eee</a><p> some text </p> and <li>text</li> <li/> <a/> <a />
<ul> </ul>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}