import re
regex = re.compile(r"^[a-zA-Z0-9][a-zA-Z0-9][a-zA-Z0-9]-[a-zA-Z0-9][a-zA-Z0-9][a-zA-Z0-9]-.+$", flags=re.MULTILINE)
test_str = ("UEF-KH1-errttz\n"
"B4A-F6F-öweiuj\n"
"ABC-DEF-17-021\n"
"AB-DEF-17-021\n"
"ABC-DEF-1\n"
"ABC-DEF\n"
"ABC-DEF-\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")