re = /^[a-zA-Z0-9][a-zA-Z0-9][a-zA-Z0-9]-[a-zA-Z0-9][a-zA-Z0-9][a-zA-Z0-9]-.+$/m
str = 'UEF-KH1-errttz
B4A-F6F-öweiuj
ABC-DEF-17-021
AB-DEF-17-021
ABC-DEF-1
ABC-DEF
ABC-DEF-
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end