import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\h|(?:.*\\h){4})[A-Za-z0-9\\h]{3,50}(?<!\\h)$";
final String string = "abc\n"
+ "abc 123\n"
+ "abc 1 2 3\n"
+ "abc 1 2 3 4\n\n"
+ " abc\n"
+ "abc ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}