const regex = new RegExp('^(?!\\h|(?:.*\\h){4})[A-Za-z0-9\\h]{3,50}(?<!\\h)$', 'gm')
const str = `abc
abc 123
abc 1 2 3
abc 1 2 3 4
abc
abc `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}