re = /^(?!\h|(?:.*\h){4})[A-Za-z0-9\h]{3,50}(?<!\h)$/m
str = 'abc
abc 123
abc 1 2 3
abc 1 2 3 4
abc
abc '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end