import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?>(?:(?:^|,|\\r?\\n)\\s*)(?:\"[^\"\\\\]*(?:\\\\[\\S\\s][^\"\\\\]*)*\"(?:\\s*(?:(?=,|\\r?\\n)|$))|[^,]*(?:\\s*(?:(?=,)|$))))*?(?>(?:^|,|\\r?\\n)\\s*)\\K\"([^\"\\\\]*?(?:\\\\[\\S\\s][^\"\\\\]*?)*,[^\"\\\\]*(?:\\\\[\\S\\s][^\"\\\\]*)*)\"";
final String string = "243,\"p s\",\"\",\"\",\"\",\"Smith, Ph.D.\",\"11872\",\"Canada\",\"\",29,,,\"\",\"\",\"\",\"\",\"\",\"\",\"UT\",\"\",,\"\",\"Bic. Gaspe\",,,,\"Dry cliffs\",,\"\",\"\",\"\",\"\",\"47633\",\"\",\"\",\"\",\"\",1938,7,126839\n\n"
+ "ID,NAME,TITLE,DESCRIPTION,,\n"
+ "PRO1234,\"JOHN SMITH\",ENGINEER,\"JOHN HAS BEEN WORKING\n\n"
+ "HARD ON BEING A GOOD\n\n"
+ "SERVENT.\"\n"
+ "PRO1235,\"KEITH SMITH\",ENGINEER,\"keith, has been working\n\n"
+ "hard on being a good\n\n"
+ "servent.\"\n"
+ "PRO1235,\"KENNY SMITH\",,\"keith has been working\n\n"
+ "hard on being a good\n\n"
+ "servent.\"\n"
+ "PRO1235,\"RICK SMITH\",,,";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}