const regex = /(?>(?:(?:^|,|\r?\n)\s*)(?:"[^"\\]*(?:\\[\S\s][^"\\]*)*"(?:\s*(?:(?=,|\r?\n)|$))|[^,]*(?:\s*(?:(?=,)|$))))*?(?>(?:^|,|\r?\n)\s*)\K"([^"\\]*?(?:\\[\S\s][^"\\]*?)*,[^"\\]*(?:\\[\S\s][^"\\]*)*)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?>(?:(?:^|,|\\r?\\n)\\s*)(?:"[^"\\\\]*(?:\\\\[\\S\\s][^"\\\\]*)*"(?:\\s*(?:(?=,|\\r?\\n)|$))|[^,]*(?:\\s*(?:(?=,)|$))))*?(?>(?:^|,|\\r?\\n)\\s*)\\K"([^"\\\\]*?(?:\\\\[\\S\\s][^"\\\\]*?)*,[^"\\\\]*(?:\\\\[\\S\\s][^"\\\\]*)*)"', 'g')
const str = `243,"p s","","","","Smith, Ph.D.","11872","Canada","",29,,,"","","","","","","UT","",,"","Bic. Gaspe",,,,"Dry cliffs",,"","","","","47633","","","","",1938,7,126839
ID,NAME,TITLE,DESCRIPTION,,
PRO1234,"JOHN SMITH",ENGINEER,"JOHN HAS BEEN WORKING
HARD ON BEING A GOOD
SERVENT."
PRO1235,"KEITH SMITH",ENGINEER,"keith, has been working
hard on being a good
servent."
PRO1235,"KENNY SMITH",,"keith has been working
hard on being a good
servent."
PRO1235,"RICK SMITH",,,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}