#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a href[^>]*>[^>]*(del)[^>]*<\/a>"
Local $sString = "<a href=http://site.ru>ok</a><a href=http://site.ru>text >del text</a>" & @CRLF & _
"<a href=http://site.ru>text ok text</a>" & @CRLF & _
"<a href=http://site.ru>text ok text</a>" & @CRLF & _
"<a href=http://site.ru>text del text</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")