const regex = /<a href[^>]*>[^>]*(del)[^>]*<\/a>/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a href[^>]*>[^>]*(del)[^>]*<\\\/a>', 'mg')
const str = `<a href=http://site.ru>ok</a><a href=http://site.ru>text >del text</a>
<a href=http://site.ru>text ok text</a>
<a href=http://site.ru>text ok text</a>
<a href=http://site.ru>text del text</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}