// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<a href[^>]*>[^>]*(del)[^>]*<\/a>").unwrap();
let string = "<a href=http://site.ru>ok</a><a href=http://site.ru>text >del text</a>
<a href=http://site.ru>text ok text</a>
<a href=http://site.ru>text ok text</a>
<a href=http://site.ru>text del text</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}