using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href[^>]*>(?:(?!<\/a>).)*(del)(?:(?!<\/a>).)*<\/a>";
string input = @"<a href=http://site.ru>ok</a><a href=http://site.ru>text >del text</a>
<a href=http://site.ru>text ok text</a>
<a href=http://site.ru>text ok text</a>
<a href=http://site.ru>text del text</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}