import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a href[^>]*>(?:(?!<\\/a>).)*(del)(?:(?!<\\/a>).)*<\\/a>";
final String string = "<a href=http://site.ru>ok</a><a href=http://site.ru>text >del text</a>\n"
+ "<a href=http://site.ru>text ok text</a>\n"
+ "<a href=http://site.ru>text ok text</a>\n"
+ "<a href=http://site.ru>text del text</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}