$re = '/<a href[^>]*>(?:(?!<\/a>).)*(del)(?:(?!<\/a>).)*<\/a>/m';
$str = '<a href=http://site.ru>ok</a><a href=http://site.ru>text >del text</a>
<a href=http://site.ru>text ok text</a>
<a href=http://site.ru>text ok text</a>
<a href=http://site.ru>text del text</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);