#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)“HttpStatus” : 400,.*“ErrorCode” : “40000”"
Local $sString = "“UserMessage” : “Bad Request”," & @CRLF & _
"“DeveloperMessage” : xxxxxxxxxxxxxxxxxcxxx" & @CRLF & _
"“HttpStatus” : 400," & @CRLF & _
"“ErrorCode” : “40000”," & @CRLF & _
"“GatewayErrors : “xxxx”" & @CRLF & _
"Xxxxxx" & @CRLF & _
"Xxxxxx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")