using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"“HttpStatus” : 400,.*“ErrorCode” : “40000”";
string input = @"“UserMessage” : “Bad Request”,
“DeveloperMessage” : xxxxxxxxxxxxxxxxxcxxx
“HttpStatus” : 400,
“ErrorCode” : “40000”,
“GatewayErrors : “xxxx”
Xxxxxx
Xxxxxx";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}