$re = '/“HttpStatus” : 400,.*“ErrorCode” : “40000”/ms';
$str = '“UserMessage” : “Bad Request”,
“DeveloperMessage” : xxxxxxxxxxxxxxxxxcxxx
“HttpStatus” : 400,
“ErrorCode” : “40000”,
“GatewayErrors : “xxxx”
Xxxxxx
Xxxxxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);