using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?!#)(?:.*run\s)?(\bride\b).*?(\bmount\b|\bdismount\b)";
string input = @"ride <target> mount <vehicle>
Makes <target> ride on <vehicle>.
ride <target> dismount";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}