import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "\\s*(?!#)(?:.*run\\s)?(\\bride\\b).*?(\\bmount\\b|\\bdismount\\b)";
        final String string = "ride <target> mount <vehicle>\n"
	 + "Makes <target> ride on <vehicle>.\n"
	 + "ride <target> dismount";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}