re = /\s*(?!#)(?:.*run\s)?(\bride\b).*?(\bmount\b|\bdismount\b)/i
str = 'ride <target> mount <vehicle>
Makes <target> ride on <vehicle>.
ride <target> dismount'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end