#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?:\/[A-Za-z0-9-]+)+)?(\/tag\/[A-Za-z0-9-%]+)+(\/.*)?"
Local $sString = "http://example.com/cat1/subcat3/subcat4/tag/this%20is%20page/asdasda?start=130/asdasdasd" & @CRLF & _
"http://example.com/cat1/subcat3/subcat4/tag/this%20is%20pageasdasd" & @CRLF & _
"example.it/news/tag/this%is%20n%page?adsadsadasd" & @CRLF & _
"http://example.com/tag/thispage/asdasdasd.-?asds=" & @CRLF & _
"http://example.com/tag/this%20is%20page/asdasd" & @CRLF & _
"http://example.com/tag/this" & @CRLF & _
""
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)