import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\/[A-Za-z0-9-]+)+)?(\\/tag\\/[A-Za-z0-9-%]+)+(\\/.*)?";
final String string = "http://example.com/cat1/subcat3/subcat4/tag/this%20is%20page/asdasda?start=130/asdasdasd\n"
+ "http://example.com/cat1/subcat3/subcat4/tag/this%20is%20pageasdasd\n"
+ "example.it/news/tag/this%is%20n%page?adsadsadasd\n"
+ "http://example.com/tag/thispage/asdasdasd.-?asds=\n"
+ "http://example.com/tag/this%20is%20page/asdasd\n"
+ "http://example.com/tag/this\n";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}