#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\h*<!-- ARTICOL START -->\R|\G)\K(?:(<p class=.*?</p>\R?)|(?:(?!<p class=.*?</p>)[\s\S])+)(?=[\s\S]+<!-- ARTICOL FINAL -->)"
Local $sString = " <!-- ARTICOL START -->" & @CRLF & _
"" & @CRLF & _
"<div align="justify">" & @CRLF & _
" <table width="682" border="0">" & @CRLF & _
" <tr>" & @CRLF & _
" <td><h1 class="den_articol" itemprop="sfe">My text here</h1></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td class="text_dreapta">On Ianuarie 14, 2014, in <a href="https://neculaifantanaru.com/en/qualities-of-a-leader.html" title="See al articles from Qualities of a leader" class="external" rel="category tag">Qualities of a leader</a>, by Author</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </table>" & @CRLF & _
" <h2 class="text_obisnuit2"><img src="index_files/sfa.jpg" width="718" height="605" id="sfs" usemap="#m_dgrnt" alt="hip" /><map name="tfAbonament" id="m_34">" & @CRLF & _
"<area shape="rect" coords="259,545,457,582" href="#plata" alt="" />" & @CRLF & _
"</map></h2>" & @CRLF & _
" <p class="den_articol">Why this text text?</p>" & @CRLF & _
"<p class="text_obisnuit">test text text</p>" & @CRLF & _
" <p class="text_obisnuit">test text text</p>" & @CRLF & _
" <p class="text_obisnuit2">test text text</p>" & @CRLF & _
" </div>" & @CRLF & _
" <p align="justify" class="text_obisnuit style3"> </p>" & @CRLF & _
" " & @CRLF & _
" <!-- ARTICOL FINAL -->"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)