re = /(?:\h*<!-- ARTICOL START -->\R|\G)\K(?:(<p class=.*?<\/p>\R?)|(?:(?!<p class=.*?<\/p>)[\s\S])+)(?=[\s\S]+<!-- ARTICOL FINAL -->)/m
str = ' <!-- ARTICOL START -->
<div align="justify">
<table width="682" border="0">
<tr>
<td><h1 class="den_articol" itemprop="sfe">My text here</h1></td>
</tr>
<tr>
<td class="text_dreapta">On Ianuarie 14, 2014, in <a href="https://neculaifantanaru.com/en/qualities-of-a-leader.html" title="See al articles from Qualities of a leader" class="external" rel="category tag">Qualities of a leader</a>, by Author</td>
</tr>
</table>
<h2 class="text_obisnuit2"><img src="index_files/sfa.jpg" width="718" height="605" id="sfs" usemap="#m_dgrnt" alt="hip" /><map name="tfAbonament" id="m_34">
<area shape="rect" coords="259,545,457,582" href="#plata" alt="" />
</map></h2>
<p class="den_articol">Why this text text?</p>
<p class="text_obisnuit">test text text</p>
<p class="text_obisnuit">test text text</p>
<p class="text_obisnuit2">test text text</p>
</div>
<p align="justify" class="text_obisnuit style3"> </p>
<!-- ARTICOL FINAL -->'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result