import re
regex = re.compile(r"(?:\h*<!-- ARTICOL START -->\R|\G)\K(?:(<p class=.*?</p>\R?)|(?:(?!<p class=.*?</p>)[\s\S])+)(?=[\s\S]+<!-- ARTICOL FINAL -->)", flags=re.MULTILINE)
test_str = (" <!-- ARTICOL START -->\n\n"
"<div align=\"justify\">\n"
" <table width=\"682\" border=\"0\">\n"
" <tr>\n"
" <td><h1 class=\"den_articol\" itemprop=\"sfe\">My text here</h1></td>\n"
" </tr>\n"
" <tr>\n"
" <td class=\"text_dreapta\">On Ianuarie 14, 2014, in <a href=\"https://neculaifantanaru.com/en/qualities-of-a-leader.html\" title=\"See al articles from Qualities of a leader\" class=\"external\" rel=\"category tag\">Qualities of a leader</a>, by Author</td>\n"
" </tr>\n"
" </table>\n"
" <h2 class=\"text_obisnuit2\"><img src=\"index_files/sfa.jpg\" width=\"718\" height=\"605\" id=\"sfs\" usemap=\"#m_dgrnt\" alt=\"hip\" /><map name=\"tfAbonament\" id=\"m_34\">\n"
"<area shape=\"rect\" coords=\"259,545,457,582\" href=\"#plata\" alt=\"\" />\n"
"</map></h2>\n"
" <p class=\"den_articol\">Why this text text?</p>\n"
"<p class=\"text_obisnuit\">test text text</p>\n"
" <p class=\"text_obisnuit\">test text text</p>\n"
" <p class=\"text_obisnuit2\">test text text</p>\n"
" </div>\n"
" <p align=\"justify\" class=\"text_obisnuit style3\"> </p>\n"
" \n"
" <!-- ARTICOL FINAL -->")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)