const regex = /(?ms)^(?<string>.*)\s+Actual start/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?ms)^(?<string>.*)\\s+Actual start', 'g')
const str = `tomec error on mos order 4006, location is ok, but numberseries 24034800-4899 = 100 numbers has failed towards tomec.
Actual start: 2017-09-08 11:54:46
Business impact:
? Customers 100000 numbers is Down no Calls in or out.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}