use strict;
my $str = 'time: 2017-12-24 13:13:34 +0000; A: 61792; B: (
60328,
60344,
60344,
60344
); C: (
"-3672",
"-3656",
1547,
1578
); D(
1500,
1484,
1500,
); E: (
313,
328
)
time: 2017-12-25 13:13:35 +0000; A: 6134; B: (
628,
60374,
6044
); C: (
"-72",
"6",
157,
157
); D(
1700,
1654,
1580,
); E: (
3103,
3208
)';
my $regex = qr/((?<=time:.).*?(?=;))|((?<=A:.).*?(?=;))|((?<=B:.\().*?(?=\)))|((?<=C:.\().*?(?=\)))|((?<=D\().*?(?=\)))|((?<=E:.\().*?(?=\)))/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}