re = /((?<=time:.).*?(?=;))|((?<=A:.).*?(?=;))|((?<=B:.\().*?(?=\)))|((?<=C:.\().*?(?=\)))|((?<=D\().*?(?=\)))|((?<=E:.\().*?(?=\)))/
str = 'time: 2017-12-24 13:13:34 +0000; A: 61792; B: (
60328,
60344,
60344,
60344
); C: (
"-3672",
"-3656",
1547,
1578
); D(
1500,
1484,
1500,
); E: (
313,
328
)
time: 2017-12-25 13:13:35 +0000; A: 6134; B: (
628,
60374,
6044
); C: (
"-72",
"6",
157,
157
); D(
1700,
1654,
1580,
); E: (
3103,
3208
)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end