import re
regex = re.compile(r"(<[^>]*>|.cs[^}]*})", flags=re.MULTILINE)
test_str = ("<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\" \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd\">\n"
"<html xmlns=\"http://www.w3.org/1999/xhtml\">\n"
" <head>\n"
" <meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\" /><title>\n"
" </title>\n"
" <style type=\"text/css\">\n"
" .csC583D0C8{text-align:left;text-indent:0pt;margin:12pt 0pt 12pt 0pt}\n"
" .csCABEF5ED{color:#282832;background-color:transparent;font-family:Arial;font-size:10pt;font-weight:bold;font-style:normal;}\n"
" </style>\n"
" </head>\n"
" <body>\n"
" <p class=\"csC583D0C8\"><span class=\"csCABEF5ED\">Test row 1<br/>Test row2</span></p></body>\n"
"</html>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")