import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*?[a-z])(?=.*?[A-Z])(?=.*?\\d)[A-Za-z\\d@$!%*#?&]{6,}$";
final String string = "yoU9&09\n"
+ "turn\n"
+ "FFFFFFFF\n"
+ "pa55W0rd\n"
+ "oeoj90I";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}