#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i).*\b(?:ronaldo|messi|kohli|jordan)\b.*\b(?:football|hockey|cricket)\b.*"
Local $sString = "fgvdf Ronaldo is the highest paid player in Football."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")