const regex = /.*\b(?:ronaldo|messi|kohli|jordan)\b.*\b(?:football|hockey|cricket)\b.*/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\b(?:ronaldo|messi|kohli|jordan)\\b.*\\b(?:football|hockey|cricket)\\b.*', 'i')
const str = `fgvdf Ronaldo is the highest paid player in Football.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}