re = /.*\b(?:ronaldo|messi|kohli|jordan)\b.*\b(?:football|hockey|cricket)\b.*/i
str = 'fgvdf Ronaldo is the highest paid player in Football.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end