using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+\.sh.+?(https?:\/\/[^\s]*)|\s+-[a-z]+\s+([\w=]+)";
string input = @"./some_script.sh http://some.server.com -p a=value -p b=value -p c=value
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}