re = /.+\.sh.+?(https?:\/\/[^\s]*)|\s+-[a-z]+\s+([\w=]+)/m
str = './some_script.sh http://some.server.com -p a=value -p b=value -p c=value
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end