package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+\.sh.+?(https?:\/\/[^\s]*)|\s+-[a-z]+\s+([\w=]+)`)
var str = `./some_script.sh http://some.server.com -p a=value -p b=value -p c=value
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}