#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[a-zA-Z0-9]+(?:,[^\S\n]*[a-zA-Z0-9]+)*(?:\n[a-zA-Z0-9]+(?:,[^\S\n]*[a-zA-Z0-9]+)*)*$"
Local $sString = "TEST12345, R5045876" & @CRLF & _
"EUDONOT1234, EF2345Y" & @CRLF & _
"AB345EEI2,FT0123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")