import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9]+(?:,[^\\S\\n]*[a-zA-Z0-9]+)*(?:\\n[a-zA-Z0-9]+(?:,[^\\S\\n]*[a-zA-Z0-9]+)*)*$";
final String string = "TEST12345, R5045876\n"
+ "EUDONOT1234, EF2345Y\n"
+ "AB345EEI2,FT0123";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}