const regex = /^[a-zA-Z0-9]+(?:,[^\S\n]*[a-zA-Z0-9]+)*(?:\n[a-zA-Z0-9]+(?:,[^\S\n]*[a-zA-Z0-9]+)*)*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9]+(?:,[^\\S\\n]*[a-zA-Z0-9]+)*(?:\\n[a-zA-Z0-9]+(?:,[^\\S\\n]*[a-zA-Z0-9]+)*)*$', '')
const str = `TEST12345, R5045876
EUDONOT1234, EF2345Y
AB345EEI2,FT0123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}