const regex = /(?<=\s.*)\s+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s.*)\\s+', 'gm')
const str = `ab defghijk lmnop qrstuv wx y z`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);