re = /(?<=\s.*)\s+/m
str = 'ab defghijk lmnop qrstuv wx y z'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result