package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{((?:[^{}]|(?R))*)\}`)
var str = `Eu sou uma string {dentro de uma string {dentro de outra} }
String {com {vários {níveis {de } chaves}} aninhadas}.
String {com mais {de} um} trecho {com {chaves}}
String com {chaves {desbalanceadas}
Chaves {} vazias
Apenas {um par de} chaves
Somente abre { chaves.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}