import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{((?:[^\\{\\}]|(?R))*)\\}";
final String string = "Eu sou uma string {dentro de uma string {dentro de outra} }\n"
+ "String {com {vários {níveis {de } chaves}} aninhadas}.\n"
+ "String {com mais {de} um} trecho {com {chaves}}\n"
+ "String com {chaves {desbalanceadas}\n"
+ "Chaves {} vazias\n"
+ "Apenas {um par de} chaves\n"
+ "Somente abre { chaves.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}