package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\<([0-9]{1,3})\>(\d{0,2}) (\-|[\S]+) (\-|[\S]{1,255}) (\-|[\S]{1,48}) (\-|[\S]{1,128}) (\-|[\S]{1,32}) (\-|\[[\S\s]+\]) ([\S\s]+){0,1}`)
var str = `<165>1 2003-10-11T22:14:15.003Z mymachine.example.com evntslog - ID47 [exampleSDID@32473 iut="3" eventSource="Application" eventID="1011"] An application event log entry...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}