import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\<([0-9]{1,3})\\>(\\d{0,2}) (\\-|[\\S]+) (\\-|[\\S]{1,255}) (\\-|[\\S]{1,48}) (\\-|[\\S]{1,128}) (\\-|[\\S]{1,32}) (\\-|\\[[\\S\\s]+\\]) ([\\S\\s]+){0,1}";
final String string = "<165>1 2003-10-11T22:14:15.003Z mymachine.example.com evntslog - ID47 [exampleSDID@32473 iut=\"3\" eventSource=\"Application\" eventID=\"1011\"] An application event log entry...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}