const regex = /^\<([0-9]{1,3})\>(\d{0,2}) (\-|[\S]+) (\-|[\S]{1,255}) (\-|[\S]{1,48}) (\-|[\S]{1,128}) (\-|[\S]{1,32}) (\-|\[[\S\s]+\]) ([\S\s]+){0,1}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\<([0-9]{1,3})\\>(\\d{0,2}) (\\-|[\\S]+) (\\-|[\\S]{1,255}) (\\-|[\\S]{1,48}) (\\-|[\\S]{1,128}) (\\-|[\\S]{1,32}) (\\-|\\[[\\S\\s]+\\]) ([\\S\\s]+){0,1}', 'g')
const str = `<165>1 2003-10-11T22:14:15.003Z mymachine.example.com evntslog - ID47 [exampleSDID@32473 iut="3" eventSource="Application" eventID="1011"] An application event log entry...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}