# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[phy\]\[[^\]\[]*\]\[([^\]\[]*)\]/$1/gm;t' <<< "case 1 is good [phy][hu][get] my dog is [hy][iu][put] [phy][hu][gotcha]"